Eckbanner

Felix hat mich auf die Idee gebracht, den kleinen Smilie aus meiner Ecke zum Verlinken anzubieten. Gesagt, getan!

Zu allererst benötigt ihr ein klein wenig CSS:

a#fbutton {
position: fixed;
z-index: 2000;
right: 0;
bottom: 0;
text-decoration: none;
text-indent: -999em;
height: 100px;
width: 100px;
background: url(http://www.greensmilies.com/smile/smiley_emoticons_eckbanner01.gif) bottom right no-repeat;
display: block;
}

Den Pfad müsst ihr durch euren Pfad zum Bild ersetzen! Der Code selbst gehört in eine CSS-Datei eurer Wahl, bei WordPress ist das meist die style.css in eurem Theme-Ordner. Dann braucht ihr natürlich noch das Bild selbst:

Smileys by GreenSmilies.com
(Rechts anklicken und speichern, darauf könnt ihr verzichten, wenn ihr die Direkt-Verlinkung aus dem CSS-Code beibehält! Achtet darauf, dass die komplette URL in einer Zeile steht.)

Zum Schluss braucht ihr noch eine Zeile HTML-Code, welchen ihr vor dem Ende des body-Tags einbaut, also ans Ende der Seite.

<a id="fbutton" href="http://www.greensmilies.com/">Smileys by GreenSmilies.com</a>

Fertig!

Leider funktioniert die Positionierung in der rechten unteren Ecke nur bei Browsern, die mit „fixed“ umgehen können, der Internet Explorer 6 ist einer der Kandidaten, der das nicht beherrscht. Alle anderen Browser sollten den Smilie korrekt darstellen, war ja klar, das nur Microsoft so etwas nicht gebacken bekommt.

Zum Schluss noch ein Schildersmilie mit welchem ich mein Smilie-Album gerne verlinke.

Smileys by GreenSmilies.com

Dieser Beitrag wurde unter Green Smilies, Green Smilies intern abgelegt und mit , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

41 Responses to Eckbanner

  1. Sebastian sagt:

    Tolle "Banner"! Smilie by GreenSmilies.com

  2. Calaelen sagt:

    "Leider funktioniert die Positionierung inur bei Browsern, die mit “fixed” umgehen können, der Internet Explorer 6" […]

    Wie du schon sagtest, funktioniert nur bei Browsern. IE6 ist ein Krampf, aber kein Browser!

    *erinner an unseren Email Dialog bzgl. JS-Fehler in IE6*

  3. prinzzess sagt:

    WIE GEIL! suuuper!

  4. Felix sagt:

    Also erst mal: Danke! Aber bei mir fuktioniert es nicht ::(: Am Browser kann es nicht liegen weil es hier ja auch klappt. [url=“http://efg9b.ef.funpic.de/phpBB2/index.php“]|Link zu meinem Forum|[/url] (Falls jemand auf die Idee kommen sollte sich zumelden: Das Forum ist nur für meine Klasse zugänglich :;):)
    Wenn das aber genau der Code ist den du auch benutzt müsste es ja eigendlich klappen… :hilfe:

  5. Felix sagt:

    Erst mal:Danke ::):

    Nur gibt’s schon ein Problem. Es wird nich da angezeigt wo es eigendlich hinsoll… :motz:
    Am Browser kann es nicht liegen, weil es ja hier auch funktioniert. Am Code auch nicht (Ich hab extra noch in deiner *.css nachgeguckt ob du nicht vieleicht nen Fehler gemacht hast^^)
    Aber woran kann das sonst noch liegen? *ratlosigkeit*
    Hier mal der Link zu ’ner Testseite von meinem Forum: http://efg9b.ef.funpic.de/test.html
    (Ja ich weiß, das Layout ist WkW ein klein bisschen ähnlich :ugly: )

  6. michael sagt:

    Der Zeilenumbruch in der URl im CSS muss raus, steht auch oben! :;):

  7. Felix sagt:

    Mhhh. Klappt immer noch nicht ::(: :hilfe:
    Der Smilie wurde ja auch schon angezeigt als der Zeilenumbruch noch da war und das Bild ist ja nur in dieser Zeile definiert…

  8. michael sagt:

    Bei mir gehts, leere deinen Browser-Cache! Z.B. SHIFT + mit der Maus reload drücken.

  9. Wanda sagt:

    Bei mir wird der Smilie auch im IE richtig angezeigt? Weiss nicht, was du hast…?

  10. michael sagt:

    Du hast vermutlich einen IE > 6

  11. Wanda sagt:

    Aha! :ugly: Könnte gut sein, ich verwende aber für gewöhnlich nur FF. :lachtot:

  12. Felix sagt:

    Chache ist gelöscht. Und was passiert? Nix. .____.
    Naja ich warte einfach mal. Das hat schonmal geholfen. Hab zwar keine Ahnung warum, aber da war so ein Ähnliches Problem, wo man auch den Browser-Chache löschen musste… Da ging’s 2 Stunden danach plötzlich.^^

  13. michael sagt:

    es geht aber definitiv auf deiner Seite! :;): Probier mal einen anderen Browser, wenn es dann immer noch nicht geht, dann hängst du an einem Proxy-Cache.

  14. Felix sagt:

    Ahhhh. Im FF geht’s. Super! ::):
    Der IE braucht wohl nur seine Zeit^^

  15. Mttao sagt:

    ::D:ich LIEBE diese Smilies ::): habe eine Frage. Darf man deine Smilies downloaden und umpainten und diese dann in einem Forum nutzen, wenn ich deine Seite im Forum verlinke? :hilfe:

  16. michael sagt:

    Was verstehst du genau unter „umpainten“ bzw. was hast du den genau vor daran zu ändern?

  17. SuMu sagt:

    früher sagte man dazu umfärben :lachtot:

  18. Loilo sagt:

    @Felix: Welche IE-Version hast du?
    Der IE < Version 7 kennt das CSS-Attribut „fixed“ nicht, das dafür sorgt, dass der Smiley in der unteren rechten Ecke erscheint.

    Mögliche Lösung wäre das:
    Position: fixed für Internet Explorer und andere Browser
    Wobei natürlich die Frage ist, ob du dir das für einen Smiley antun willst :;):

  19. michael sagt:

    @ SuMu

    Das dachte ich mir schon, ich wollte nur sicher gehen, dass auch wirklich nur das reine Umfärben gemeint ist!

    @ Loilo

    IE 6 gehört sowieso vom Markt, von daher kein Support für diesen Krüppelbrowser.

  20. Loilo sagt:

    Natürlich gehört der vom Markt, aber was soll man machen – muss man halt auch unterstützen…

    http://barrierefrei.e-workers.de/images/wsp3.gif :;):

  21. AveN sagt:

    Ich werde den ganz sicher nicht unterstützen… meine kommende Seite wird lesbar sei nfür den ie6, aber absolut hässlich.. und das ist mir egal!!

    LG AveN

  22. Loilo sagt:

    Schreib doch hin: "Sie benutzen einen absolut veralteten, strohdoofen und gemeingefährlichen Browser!" (Denn das ist der Internet Explorer mit Sicherheit…)

    :XD:

  23. Saya sagt:

    Also wirklich, du untertreibst mal wieder, lolo…
    du hast lahmarschig, hirnrissig und :motz: – Anfälle hervorrufend vergessen. oh, ach und natürlich hast du vergessen zu sagen: von microsoft (ersetzt alle eben genannten attribute :;): )

    @felix:
    heißt das, du hast die ganze zeit gefragt warum das nicht funktioniert und dabei ie benutzt, obwohl oben stand, dass es im ie nicht funktioniert? :wallbash:
    nichts gegen dich, aber wenn da steht:
    "Leider funktioniert die Positionierung in der rechten unteren Ecke nur bei Browsern, die mit “fixed” umgehen können, der Internet Explorer 6 ist einer der Kandidaten, der das nicht beherrscht."
    dürfte es eigentlich klar sein, dass man das nicht mit ie öffnet, oder sich wenn man es damit öffnet sich wenigstens nicht darüber beschwert, dass es nicht funktioniert.

    @alle:
    wie mir aufgefallen ist vertauscht mein opera öfters ma die smileys auf deiner seite… (grade ebend auch… wenn beim motz-smiley shocked angezeigt wird, kann da ja was nich stimmen) Hab keine Ahnung was ich machn muss, damit opera das wieder auf die reihe kriegt… Ich hätt natürlich lolo ausquetschn könn, aber wo ich schonmal beim schreiben bin, dacht ich mir ich schreib das gleich nochma dazu.

    Mfg Saya

    edit: huch? bisschen lang..

  24. michael sagt:

    Lang, macht doch nichts!

    Probier mal den Cache deines Opera zu leeren, mir ist aber so etwas noch nie zu Ohren kommen… ich kenn da aber zwei Opera-User, vielleicht haben die eine Idee.

  25. michael sagt:

    @ Saya

    Kann es sein, dass es an der Ladeverzögerung liegt, also ein Smilie nach dem Laden des Motz-Smiley geladen wird und dann verschoben wird?

Kommentare sind geschlossen.